AWS US-WEST-1 Region Is Down, Plivo REST APIs and XML Impacted
Incident Report for Trackdrive
Resolved
AWS has restored normal service.
Posted over 2 years ago. Feb 10, 2017 - 07:38 EST
Update
ISSUE: AWS is working on the network failures in us-west-1. You can track their progress here: http://status.aws.amazon.com/
Posted over 2 years ago. Feb 09, 2017 - 21:40 EST
Update
REST APIs and XML

ISSUE: We are impacted by a network outage on AWS us-west-1 zone. We will update shortly our status page with an update.

https://status.plivo.com/incident/api/2017/02/10/
Posted over 2 years ago. Feb 09, 2017 - 21:18 EST
Monitoring
Outbound calls on Plivo are taking longer than usual to dial.
Posted over 2 years ago. Feb 09, 2017 - 20:55 EST