Plivo Outbound Call Failure
Incident Report for Trackdrive
Resolved
Calls are routing fine. Call recordings are still unavailable until plivo's DNS comes back online.
Posted almost 2 years ago. Apr 23, 2017 - 20:24 EDT
Update
Incoming and outgoing calls through Plivo are now back online.
Posted almost 2 years ago. Apr 23, 2017 - 16:12 EDT
Update
Update From Plivo:

Due to an error with our domain registrar “plivo.com” and all its subdomains are unreachable currently. We have now identified and resolved the configuration issue with the domain registrar.
We expect the DNS to propagate globally within the next few hours and all services should be back up then using the “plivo.com’ domain.
Meanwhile, we have created this working document which will provide live status updates. The same document also provides instructions on how to switch to using IPs at your end to ensure Plivo services are back up immediately.
We apologize for the inconvenience, we are doing our best to get the services back up.
Posted almost 2 years ago. Apr 23, 2017 - 15:30 EDT
Update
Plivo has provided an update:

Description
We are experiencing an issue with the DNS resolution of plivo.com domains due to a registrar renewal expiration. We are actively working on resolving the issue.

Timeline
Sun Apr 23 13:22:10 UTC 2017
We are working with our provider to expedite the renewal of the DNS. We will update you shortly.
Posted almost 2 years ago. Apr 23, 2017 - 09:52 EDT
Monitoring
Plivo is currently seeing a high rate of outbound calls failing. Plivo's engineering team is currently investigating the issue.
Posted almost 2 years ago. Apr 23, 2017 - 08:28 EDT