Account Portal Unreachable
Incident Report for Trackdrive
Resolved
Normal service is restored.

About 3 hours ago we switched our DNS back to AWS since cloudflare.com was having connectivity issues to our AWS load balancer.
Posted about 2 years ago. Jun 19, 2017 - 13:35 EDT
Monitoring
Cloudflare continues to have difficulty connecting to our AWS ELB loadbalancers. Cloudflare and AWS are investigating.

As an immediate solution we have updated our domain's nameservers to point at AWS directly. This change was made 50 minutes ago, so trackdrive.net is back online for most of our users at this point.

If trackdrive is still unreachable try switching your browser's DNS to 8.8.8.8 to resolve domains using google.
Posted about 2 years ago. Jun 19, 2017 - 11:55 EDT
Investigating
It appears that the trackdrive.net account interface is unreachable for some percentage of users.

We are investigating. Our initial suspicion is that our reverse-proxy with cloudflare.com is causing the outage.

Call handling is hosted on separate dedicated hardware, so your calls are still processing correctly.
Posted about 2 years ago. Jun 19, 2017 - 10:32 EDT