Cloudflare Connection Errors From Dehli, India
Incident Report for Trackdrive
Resolved
Normal service is restored, connection errors from Dehli, India are no longer occurring.
Posted almost 2 years ago. Apr 27, 2017 - 12:10 EDT
Monitoring
A small subset of our users may be currently experiencing connection errors from New Dehli, India.

The issue is being caused by issues in Cloudflare's Indian data centres.

Cloudflare has provided this update:

We apologize for the inconvenience. We are currently working on balancing the load between our Indian data centres. We are auctioning some changes that you should be able to see over the next 15 mins.
Posted almost 2 years ago. Apr 27, 2017 - 11:21 EDT