Increased error rates across multiple services
Incident Report for Trackdrive
Resolved
AWS has restored normal service.

https://status.aws.amazon.com/

[RESOLVED] Increased Error Rates for Amazon S3

Update at 2:08 PM PST: As of 1:49 PM PST, we are fully recovered for operations for adding new objects in S3, which was our last operation showing a high error rate. The Amazon S3 service is operating normally.
Posted about 2 years ago. Feb 28, 2017 - 17:28 EST
Identified
Identified - Our main provider, AWS, is having global issues with it's CDN and File Hosting services (CloudFront and S3). We're working with them to resolve the issue.

https://status.plivo.com/
Posted about 2 years ago. Feb 28, 2017 - 13:17 EST
Investigating
We are experiencing increased error levels across multiple services.
Posted about 2 years ago. Feb 28, 2017 - 13:14 EST